Inception

function goDeeper() {
    goDeeper();
}
Vote up this code3
  • Auteur

    Actually… there should be a base condition. var kick.

    It should be:

    function goDeeper() {
    if (kick) return
    goDeeper();
    }

    • Daniel Ortiz Esquivel

      Yes this version is better

    • Ricardo Sabino

      Actually, I would change it to:
      function goDeeper() {
      if(kick) {
      if(wakeFromKick)
      return;
      else
      Limbo();
      }

      goDeeper();
      }

  • Elliot Gorokhovsky

    OHMYGOD ITS INCEPTION!!!!!!!!! cuz its a function calling a function inside a function OHMYGOD

    • Axel

      You are being cruel